CVE-2015-8877

NameCVE-2015-8877
DescriptionThe gdImageScaleTwoPass function in gd_interpolation.c in the GD Graphics Library (aka libgd) before 2.2.0, as used in PHP before 5.6.12, uses inconsistent allocate and free approaches, which allows remote attackers to cause a denial of service (memory consumption) via a crafted call, as demonstrated by a call to the PHP imagescale function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3587-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2fixed
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie (security), jessie2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-4fixed
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11vulnerable
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.26-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.1-1medium
libgd2sourcejessie2.1.0-5+deb8u3mediumDSA-3587-1
libgd2sourcewheezy(not affected)
php5source(unstable)5.6.12+dfsg-1unimportant
php5sourcejessie5.6.12+dfsg-0+deb8u1medium
php7.0source(unstable)7.0.0-1unimportant

Notes

[wheezy] - libgd2 <not-affected> (Vulnerable code not present)
https://github.com/libgd/libgd/commit/4751b606fa38edc456d627140898a7ec679fcc24 (gd-2.2.0)
https://github.com/libgd/libgd/issues/173
PHP bug: https://bugs.php.net/bug.php?id=70064
Fixed in PHP 5.6.12, 7.0.0
Starting with 5.4.0-1 Debian uses the system copy of libgd

Search for package or bug name: Reporting problems