CVE-2015-8878

NameCVE-2015-8878
Descriptionmain/php_open_temporary_file.c in PHP before 5.5.28 and 5.6.x before 5.6.12 does not ensure thread safety, which allows remote attackers to cause a denial of service (race condition and heap memory corruption) by leveraging an application that performs many temporary-file accesses.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-499-1
NVD severityhigh

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5sourcewheezy5.4.45-0+deb7u3DLA-499-1
php5sourcejessie5.6.12+dfsg-0+deb8u1
php5source(unstable)5.6.12+dfsg-1

Notes

Fixed in PHP 5.6.12, 5.5.28
PHP bug: https://bugs.php.net/bug.php?id=70002

Search for package or bug name: Reporting problems