CVE-2015-8894

NameCVE-2015-8894
DescriptionDouble free vulnerability in coders/tga.c in ImageMagick 7.0.0 and later allows remote attackers to cause a denial of service (application crash) via a crafted tga file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs799524, 806442

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)stretch8:6.9.7.4+dfsg-11+deb9u8fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u10fixed
buster, buster (security)8:6.9.10.23+dfsg-2.1+deb10u1fixed
bullseye, sid8:6.9.11.24+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksourcesqueeze(not affected)
imagemagicksourcewheezy(not affected)
imagemagicksourcejessie(not affected)
imagemagicksource(unstable)8:6.8.9.9-6799524, 806442

Notes

[jessie] - imagemagick <not-affected> (Can't reproduce crash with file)
[wheezy] - imagemagick <not-affected> (Can't reproduce crash with file)
[squeeze] - imagemagick <not-affected> (Can't reproduce crash with file)
https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1490362
https://github.com/ImageMagick/ImageMagick/commit/4f68e9661518463fca523c9726bb5d940a2aa6d8
https://www.openwall.com/lists/oss-security/2015/10/07/2
https://www.openwall.com/lists/oss-security/2016/02/22/4
The problem can only be triggered with recent versions of ImageMagick (8:6.9.1.2-1 in experimental is vulnerable, 8:6.8.9.9-6 in sid is not vulnerable, older versions are not vulnerable)

Search for package or bug name: Reporting problems