CVE-2015-8915

NameCVE-2015-8915
Descriptionbsdcpio in libarchive before 3.2.0 allows remote attackers to cause a denial of service (invalid read and crash) via crafted cpio file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1600-1, DLA-617-1
NVD severitymedium
Debian Bugs784213

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libarchive (PTS)stretch (security), stretch3.2.2-2+deb9u2fixed
buster, buster (security)3.3.3-4+deb10u1fixed
bookworm, sid, bullseye3.4.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libarchivesourcewheezy3.0.4-3+wheezy3DLA-617-1
libarchivesourcejessie3.1.2-11+deb8u4DLA-1600-1
libarchivesource(unstable)3.2.0-2low784213

Notes

[squeeze] - libarchive <no-dsa> (Minor issue)
https://github.com/libarchive/libarchive/issues/503
https://github.com/libarchive/libarchive/issues/502
502 is a duplicate of https://github.com/libarchive/libarchive/issues/503
Fixed by: https://github.com/libarchive/libarchive/commit/e6c9668f3202215ddb71617b41c19b6f05acf008
Fixed by: https://github.com/libarchive/libarchive/commit/3865cf2bcb0eebc1baef28a7841b1cadae6e0f7c

Search for package or bug name: Reporting problems