CVE-2015-8917

NameCVE-2015-8917
Descriptionbsdtar in libarchive before 3.2.0 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via an invalid character in the name of a cab file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-554-1, DSA-3657-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libarchive (PTS)jessie3.1.2-11+deb8u3fixed
jessie (security)3.1.2-11+deb8u8fixed
stretch (security), stretch3.2.2-2+deb9u2fixed
buster, buster (security)3.3.3-4+deb10u1fixed
bullseye, sid3.4.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libarchivesource(unstable)3.2.0-2
libarchivesourcejessie3.1.2-11+deb8u2DSA-3657-1
libarchivesourcewheezy3.0.4-3+wheezy2DLA-554-1

Notes

https://github.com/libarchive/libarchive/issues/505
Fixed by https://github.com/libarchive/libarchive/commit/b2e2abb

Search for package or bug name: Reporting problems