CVE-2015-8929

NameCVE-2015-8929
DescriptionMemory leak in the __archive_read_get_extract function in archive_read_extract2.c in libarchive before 3.2.0 allows remote attackers to cause a denial of service via a tar file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libarchive (PTS)stretch3.2.2-2+deb9u2fixed
stretch (security)3.2.2-2+deb9u3fixed
buster, buster (security)3.3.3-4+deb10u1fixed
bullseye3.4.3-2+deb11u1fixed
bookworm, sid3.6.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libarchivesourcewheezy(not affected)
libarchivesourcejessie(not affected)
libarchivesource(unstable)3.2.0-2

Notes

[jessie] - libarchive <not-affected> (Introduced in 3.2.0)
[wheezy] - libarchive <not-affected> (Introduced in 3.2.0)
https://github.com/libarchive/libarchive/issues/517
Fixed by: https://github.com/libarchive/libarchive/commit/d24e79e8f9547ae475a3a0c9516e079a14010838

Search for package or bug name: Reporting problems