CVE-2015-8935

NameCVE-2015-8935
DescriptionThe sapi_header_op function in main/SAPI.c in PHP before 5.4.38, 5.5.x before 5.5.22, and 5.6.x before 5.6.6 supports deprecated line folding without considering browser compatibility, which allows remote attackers to conduct cross-site scripting (XSS) attacks against Internet Explorer by leveraging (1) %0A%20 or (2) %0D%0A%20 mishandling in the header function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5sourcewheezy5.4.38-0+deb7u1
php5source(unstable)5.6.6+dfsg-1

Notes

https://bugs.php.net/bug.php?id=68978
https://github.com/php/php-src/commit/996faf964bba1aec06b153b370a7f20d3dd2bb8b
Fixed in 5.6.6, 5.5.22 and 5.4.38

Search for package or bug name: Reporting problems