CVE-2015-8959

NameCVE-2015-8959
Descriptioncoders/dds.c in ImageMagick before 6.9.0-4 Beta allows remote attackers to cause a denial of service (CPU consumption) via a crafted DDS file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-731-1, DSA-3652-1
NVD severityhigh (attack range: remote)
Debian Bugs832944

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4vulnerable
wheezy (security)8:6.7.7.10-5+deb7u18fixed
jessie8:6.8.9.9-5+deb8u9fixed
jessie (security)8:6.8.9.9-5+deb8u10fixed
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u1fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.6.2+dfsg-2high832944
imagemagicksourcejessie8:6.8.9.9-5+deb8u4highDSA-3652-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u8highDLA-731-1

Notes

http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=26861
https://github.com/ImageMagick/ImageMagick/commit/3ab016764c7f787829d9065440d86f5609765110
https://github.com/ImageMagick/ImageMagick/commit/9b428b7af688fe319320aed15f2b94281d1e37b4
http://www.openwall.com/lists/oss-security/2016/08/07/1

Search for package or bug name: Reporting problems