CVE-2015-8971

NameCVE-2015-8971
DescriptionTerminology 0.7.0 allows remote attackers to execute arbitrary commands via escape sequences that modify the window title and then are written to the terminal, a similar issue to CVE-2003-0063.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3712-1
NVD severitymedium (attack range: local)
Debian Bugs843434

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
terminology (PTS)jessie (security), jessie0.7.0-1+deb8u1fixed
sid0.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
terminologysource(unstable)0.7.0-2medium843434
terminologysourcejessie0.7.0-1+deb8u1mediumDSA-3712-1

Notes

https://git.enlightenment.org/apps/terminology.git/commit/?id=b80bedc7c21ecffe99d8d142930db696eebdd6a5
http://www.openwall.com/lists/oss-security/2016/11/04/12

Search for package or bug name: Reporting problems