CVE-2015-8983

NameCVE-2015-8983
DescriptionInteger overflow in the _IO_wstr_overflow function in libio/wstrops.c in the GNU C Library (aka glibc or libc6) before 2.22 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors related to computing a size in bytes, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-316-1
NVD severitymedium (attack range: remote)
Debian Bugs779587

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10fixed
wheezy (security)2.13-38+deb7u11fixed
glibc (PTS)jessie2.19-18+deb8u9fixed
jessie (security)2.19-18+deb8u3fixed
sid, stretch2.24-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)medium
eglibcsourcesqueeze2.11.3-4+deb6u7mediumDLA-316-1
eglibcsourcewheezy2.13-38+deb7u9medium
glibcsource(unstable)2.21-1medium779587
glibcsourcejessie2.19-18+deb8u2medium

Notes

https://sourceware.org/bugzilla/show_bug.cgi?id=17269
Fixed upstream in 2.22
Fixed by: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=bdf1ff052a8e23d637f2c838fa5642d78fcedc33
http://www.openwall.com/lists/oss-security/2015/02/22/15

Search for package or bug name: Reporting problems