CVE-2015-8984

NameCVE-2015-8984
DescriptionThe fnmatch function in the GNU C Library (aka glibc or libc6) before 2.22 might allow context-dependent attackers to cause a denial of service (application crash) via a malformed pattern, which triggers an out-of-bounds read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-316-1
NVD severitymedium (attack range: remote)
Debian Bugs779587

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10fixed
wheezy (security)2.13-38+deb7u12fixed
glibc (PTS)jessie (security), jessie2.19-18+deb8u10fixed
stretch (security), stretch2.24-11+deb9u1fixed
buster, sid2.24-14fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)medium
eglibcsourcesqueeze2.11.3-4+deb6u7mediumDLA-316-1
eglibcsourcewheezy2.13-38+deb7u9medium
glibcsource(unstable)2.21-1medium779587
glibcsourcejessie2.19-18+deb8u2medium

Notes

https://sourceware.org/bugzilla/show_bug.cgi?id=18032
https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=4a28f4d55a6cc33474c0792fe93b5942d81bf185
http://www.openwall.com/lists/oss-security/2015/02/26/5

Search for package or bug name: Reporting problems