CVE-2015-9097

NameCVE-2015-9097
DescriptionThe mail gem before 2.5.5 for Ruby (aka A Really Ruby Mail Library) is vulnerable to SMTP command injection via CRLF sequences in a RCPT TO or MAIL FROM command, as demonstrated by CRLF sequences immediately before and after a DATA substring.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-489-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-mail (PTS)jessie2.6.1+dfsg1-1fixed
stretch2.6.4+dfsg1-1fixed
bullseye, sid, buster2.7.1+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-mailsource(unstable)2.6.1+dfsg1-1medium
ruby-mailsourcewheezy2.4.4-2+deb7u1mediumDLA-489-1

Notes

https://github.com/mikel/mail/commit/72befdc4dab3e6e288ce226a7da2aa474cf5be83
CVE Request: http://www.openwall.com/lists/oss-security/2015/12/11/3
Fixed in 2.6.0
"Note that, this patch might not be complete ..." https://bugzilla.redhat.com/show_bug.cgi?id=1293598

Search for package or bug name: Reporting problems