CVE-2015-9244

NameCVE-2015-9244
DescriptionKeys of objects in mysql node module v2.0.0-alpha7 and earlier are not escaped with `mysql.escape()` which could lead to SQL Injection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-mysql (PTS)stretch2.10.2-1fixed
buster2.16.0-1+deb10u1fixed
bullseye, sid2.18.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-mysqlsource(unstable)2.0.0~alpha8-1unimportant

Notes

https://github.com/felixge/node-mysql/issues/342
https://nodesecurity.io/advisories/66
nodejs not covered by security support

Search for package or bug name: Reporting problems