CVE-2015-9284

NameCVE-2015-9284
DescriptionThe request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs973384

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-omniauth (PTS)buster1.8.1-1vulnerable
bullseye1.9.1-1vulnerable
bookworm, sid2.0.4-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-omniauthsource(unstable)(unfixed)973384

Notes

[bullseye] - ruby-omniauth <ignored> (Minor issue)
[buster] - ruby-omniauth <ignored> (Minor issue)
[stretch] - ruby-omniauth <no-dsa> (Minor issue)
[jessie] - ruby-omniauth <no-dsa> (Fix is in additional gem and needs CSRF protection in apps)
https://github.com/omniauth/omniauth/pull/809
https://www.openwall.com/lists/oss-security/2015/05/26/11

Search for package or bug name: Reporting problems