CVE-2015-9541

NameCVE-2015-9541
DescriptionQt through 5.14 allows an exponential XML entity expansion attack via a crafted SVG document that is mishandled in QXmlStreamReader, a related issue to CVE-2003-1564.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs951066

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qtbase-opensource-src (PTS)jessie5.3.2+dfsg-4+deb8u2vulnerable
jessie (security)5.3.2+dfsg-4+deb8u4vulnerable
stretch5.7.1+dfsg-3+deb9u1vulnerable
stretch (security)5.7.1+dfsg-3+deb9u2vulnerable
buster5.11.3+dfsg1-1+deb10u2vulnerable
buster (security)5.11.3+dfsg1-1+deb10u3vulnerable
bullseye, sid5.12.5+dfsg-8vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qtbase-opensource-srcsource(unstable)(unfixed)low951066

Notes

[buster] - qtbase-opensource-src <no-dsa> (Minor issue)
[stretch] - qtbase-opensource-src <no-dsa> (Minor issue)
https://bugreports.qt.io/browse/QTBUG-47417

Search for package or bug name: Reporting problems