CVE-2016-0737

NameCVE-2016-0737
DescriptionOpenStack Object Storage (Swift) before 2.4.0 does not properly close client connections, which allows remote attackers to cause a denial of service (proxy-server resource consumption) via a series of interrupted requests to a Large Object URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
swift (PTS)stretch2.10.2-1~deb9u1fixed
buster2.19.1-1fixed
bullseye, sid2.26.0-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
swiftsourcewheezy(not affected)
swiftsourcejessie(not affected)
swiftsource(unstable)2.4.0-1

Notes

[jessie] - swift <not-affected> (Vulnerable code not present)
[wheezy] - swift <not-affected> (Vulnerable code not present)
Swift: >=2.2.1 <= 2.3.0

Search for package or bug name: Reporting problems