CVE-2016-0738

NameCVE-2016-0738
DescriptionOpenStack Object Storage (Swift) before 2.3.1 (Kilo), 2.4.x, and 2.5.x before 2.5.1 (Liberty) do not properly close server connections, which allows remote attackers to cause a denial of service (proxy-server resource consumption) via a series of interrupted requests to a Large Object URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs812984

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
swift (PTS)buster2.19.1-1fixed
buster (security)2.19.1-1+deb10u1fixed
bullseye (security), bullseye2.26.0-10+deb11u1fixed
bookworm2.30.0-4fixed
sid, trixie2.33.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
swiftsourcewheezy(not affected)
swiftsourcejessie(not affected)
swiftsource(unstable)2.5.0-3812984

Notes

[jessie] - swift <not-affected> (Vulnerable code not present)
[wheezy] - swift <not-affected> (Vulnerable code not present)
Swift: >=2.2.1 <= 2.3.0, >= 2.4.0 <= 2.5.0

Search for package or bug name: Reporting problems