CVE-2016-0742

NameCVE-2016-0742
DescriptionThe resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to cause a denial of service (invalid pointer dereference and worker process crash) via a crafted UDP DNS response.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-404-1, DSA-3473-1
NVD severitymedium (attack range: remote)
Debian Bugs812806

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)wheezy1.2.1-2.2+wheezy4fixed
wheezy (security)1.2.1-2.2+wheezy4+deb7u1fixed
jessie1.6.2-5+deb8u4fixed
jessie (security)1.6.2-5+deb8u5fixed
stretch (security), stretch1.10.3-1+deb9u1fixed
buster, sid1.13.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsource(unstable)1.9.10-1medium812806
nginxsourcejessie1.6.2-5+deb8u1mediumDSA-3473-1
nginxsourcesqueeze0.7.67-3+squeeze4+deb6u1mediumDLA-404-1
nginxsourcewheezy1.2.1-2.2+wheezy4mediumDSA-3473-1

Notes

http://mailman.nginx.org/pipermail/nginx/2016-January/049700.html
https://github.com/nginx/nginx/commit/c44fd4e837f979912749a5a19490ccb9b46398d3 (release-1.9.10)

Search for package or bug name: Reporting problems