CVE-2016-0747

NameCVE-2016-0747
DescriptionThe resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 does not properly limit CNAME resolution, which allows remote attackers to cause a denial of service (worker process resource consumption) via vectors related to arbitrary name resolution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3473-1
NVD severitymedium (attack range: remote)
Debian Bugs812806

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)wheezy1.2.1-2.2+wheezy4fixed
wheezy (security)1.2.1-2.2+wheezy4+deb7u1fixed
jessie1.6.2-5+deb8u4fixed
jessie (security)1.6.2-5+deb8u5fixed
stretch (security), stretch1.10.3-1+deb9u1fixed
buster, sid1.13.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsource(unstable)1.9.10-1medium812806
nginxsourcejessie1.6.2-5+deb8u1mediumDSA-3473-1
nginxsourcesqueeze(not affected)
nginxsourcewheezy1.2.1-2.2+wheezy4mediumDSA-3473-1

Notes

[squeeze] - nginx <not-affected> (Vulnerable code not present)
http://mailman.nginx.org/pipermail/nginx/2016-January/049700.html
https://github.com/nginx/nginx/commit/4016e6b1da4fbf9c45963211791be124cd7ffb8f (release-1.9.10)
https://github.com/nginx/nginx/commit/fe89d99796d42b86816e17d9c87ab16964768024 (release-1.9.10)

Search for package or bug name: Reporting problems