CVE-2016-0753

NameCVE-2016-0753
DescriptionActive Model in Ruby on Rails 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 supports the use of instance-level writers for class accessors, which allows remote attackers to bypass intended validation steps via crafted parameters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-498-1, DLA-641-1, DLA-642-1, DSA-3464-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)wheezy2:2.3.14.2fixed
jessie (security), jessie2:4.1.8-1+deb8u4fixed
stretch, sid2:4.2.7.1-1fixed
ruby-activemodel-3.2 (PTS)wheezy3.2.6-3vulnerable
wheezy (security)3.2.6-3+deb7u1fixed
ruby-activerecord-2.3 (PTS)wheezy2.3.14-6vulnerable
ruby-activerecord-3.2 (PTS)wheezy3.2.6-5+deb7u1vulnerable
wheezy (security)3.2.6-5+deb7u3fixed
ruby-activesupport-2.3 (PTS)wheezy2.3.14-7vulnerable
ruby-activesupport-3.2 (PTS)wheezy3.2.6-6+deb7u1vulnerable
wheezy (security)3.2.6-6+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2:4.2.5.1-1medium
railssourcejessie2:4.1.8-1+deb8u1mediumDSA-3464-1
railssourcesqueeze(unfixed)end-of-life
railssourcewheezy(not affected)
ruby-activemodel-3.2source(unstable)(unfixed)medium
ruby-activemodel-3.2sourcewheezy3.2.6-3+deb7u1mediumDLA-498-1
ruby-activerecord-2.3source(unstable)(unfixed)medium
ruby-activerecord-2.3sourcewheezy(unfixed)end-of-life
ruby-activerecord-3.2source(unstable)(unfixed)medium
ruby-activerecord-3.2sourcewheezy3.2.6-5+deb7u3mediumDLA-642-1
ruby-activesupport-2.3source(unstable)(unfixed)medium
ruby-activesupport-2.3sourcewheezy(unfixed)end-of-life
ruby-activesupport-3.2source(unstable)(unfixed)medium
ruby-activesupport-3.2sourcewheezy3.2.6-6+deb7u3mediumDLA-641-1

Notes

[wheezy] - rails <not-affected> (Vulnerable code not present, is only a transitional package)
[squeeze] - rails <end-of-life> (Not supported in Squeeze LTS)

Search for package or bug name: Reporting problems