CVE-2016-0755

NameCVE-2016-0755
DescriptionThe ConnectionExists function in lib/url.c in libcurl before 7.47.0 does not properly re-use NTLM-authenticated proxy connections, which might allow remote attackers to authenticate as other users via a request, a similar issue to CVE-2014-0015.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3455-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)wheezy7.26.0-1+wheezy13vulnerable
wheezy (security)7.26.0-1+wheezy23vulnerable
jessie (security), jessie7.38.0-4+deb8u8fixed
stretch (security), stretch7.52.1-5+deb9u3fixed
buster, sid7.57.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.47.0-1medium
curlsourcejessie7.38.0-4+deb8u3mediumDSA-3455-1

Notes

[wheezy] - curl <no-dsa> (Too intrusive to backport)
http://curl.haxx.se/docs/adv_20160127A.html

Search for package or bug name: Reporting problems