CVE-2016-0757

NameCVE-2016-0757
DescriptionOpenStack Image Service (Glance) before 2015.1.3 (kilo) and 11.0.x before 11.0.2 (liberty), when show_multiple_locations is enabled, allow remote authenticated users to change image status and upload new image data by removing the last location of an image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glance (PTS)buster2:17.0.0-4fixed
buster (security)2:17.0.0-5+deb10u1fixed
bullseye (security), bullseye2:21.0.0-2+deb11u1fixed
bookworm2:25.1.0-2fixed
sid, trixie2:28.0.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glancesource(unstable)2:12.0.0-1

Notes

[jessie] - glance <no-dsa> (Minor issue)
[wheezy] - glance <no-dsa> (Minor issue)
<=2015.1.2, >=11.0.0 <= 11.0.1
https://bugs.launchpad.net/bugs/1525915

Search for package or bug name: Reporting problems