CVE-2016-0758

NameCVE-2016-0758
DescriptionInteger overflow in lib/asn1_decoder.c in the Linux kernel before 4.6 allows local users to gain privileges via crafted ASN.1 data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1fixed
jessie (security)3.16.57-2fixed
stretch4.9.110-1fixed
stretch (security)4.9.110-3+deb9u3fixed
buster4.17.14-1fixed
sid4.17.17-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.5.4-1high
linuxsourcejessie3.16.36-1high
linuxsourcewheezy(not affected)

Notes

[wheezy] - linux <not-affected> (Vulnerable code introduced in v3.10-rc1)
https://lkml.org/lkml/2016/5/12/270
https://bugzilla.redhat.com/show_bug.cgi?id=1300257
Fixed by: https://git.kernel.org/linus/23c8a812dc3c621009e4f0e5342aa4e2ede1ceaa
Introduced by: https://git.kernel.org/linus/42d5ec27f873c654a68f7f865dcd7737513e9508 (v3.10-rc1)

Search for package or bug name: Reporting problems