CVE-2016-0763

NameCVE-2016-0763
DescriptionThe setGlobalContext method in org/apache/naming/factory/ResourceLinkFactory.java in Apache Tomcat 7.x before 7.0.68, 8.x before 8.0.31, and 9.x before 9.0.0.M3 does not consider whether ResourceLinkFactory.setGlobalContext callers are authorized, which allows remote authenticated users to bypass intended SecurityManager restrictions and read or write to arbitrary application data, or cause a denial of service (application disruption), via a web application that sets a crafted global context.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-435-1, DSA-3530-1, DSA-3552-1, DSA-3609-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat6 (PTS)jessie (security), jessie6.0.45+dfsg-1~deb8u1fixed
tomcat7 (PTS)jessie7.0.56-3+deb8u11fixed
jessie (security)7.0.56-3+really7.0.100-1fixed
stretch7.0.75-1fixed
tomcat8 (PTS)jessie8.0.14-1+deb8u11fixed
jessie (security)8.0.14-1+deb8u16fixed
stretch (security), stretch8.5.50-0+deb9u1fixed
tomcat9 (PTS)buster9.0.16-4fixed
bullseye, sid9.0.31-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat6source(unstable)6.0.41-3
tomcat6sourcesqueeze6.0.45-1~deb6u1DLA-435-1
tomcat6sourcewheezy6.0.45+dfsg-1~deb7u1DSA-3530-1
tomcat7source(unstable)7.0.68-1
tomcat7sourcejessie7.0.56-3+deb8u2DSA-3552-1
tomcat7sourcewheezy7.0.28-4+deb7u4DSA-3552-1
tomcat8source(unstable)8.0.32-1
tomcat8sourcejessie8.0.14-1+deb8u2DSA-3609-1
tomcat9source(unstable)(not affected)

Notes

- tomcat9 <not-affected> (Fixed before initial upload to Debian)
Since 6.0.41-3, src:tomcat6 only builds a servlet and docs
Fixed in 6.0.45, 7.0.68, 8.0.32, 9.0.0.M3

Search for package or bug name: Reporting problems