CVE-2016-1000027

NameCVE-2016-1000027
DescriptionPivotal Spring Framework through 5.3.16 suffers from a potential remote code execution (RCE) issue if used for Java deserialization of untrusted data. Depending on how the library is implemented within a product, this issue may or not occur, and authentication may be required. NOTE: the vendor's position is that untrusted data is not an intended use case. The product's behavior will not be changed because some users rely on deserialization of trusted data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libspring-java (PTS)stretch4.3.5-1fixed
stretch (security)4.3.5-1+deb9u1fixed
buster4.3.22-4fixed
bookworm, sid, bullseye4.3.30-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libspring-javasource(unstable)4.2.7-1unimportant

Notes

https://www.tenable.com/security/research/tra-2016-20
This is not a vulnerability in Spring itself, just how applications are using it

Search for package or bug name: Reporting problems