CVE-2016-1000030

NameCVE-2016-1000030
DescriptionPidgin version <2.11.0 contains a vulnerability in X.509 Certificates imports specifically due to improper check of return values from gnutls_x509_crt_init() and gnutls_x509_crt_import() that can result in code execution. This attack appear to be exploitable via custom X.509 certificate from another client. This vulnerability appears to have been fixed in 2.11.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pidgin (PTS)jessie (security), jessie2.11.0-0+deb8u2fixed
stretch2.12.0-1fixed
buster, sid2.13.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pidginsource(unstable)2.11.0-1unimportant
pidginsourcejessie2.11.0-0+deb8u1high

Notes

http://www.pidgin.im/news/security/?id=91
https://bitbucket.org/pidgin/main/commits/d6fc1ce76ffe
Furthermore pidgin in Debian is not compiled to use GnuTLS (--enable-gnutls=no)

Search for package or bug name: Reporting problems