CVE-2016-1000111

NameCVE-2016-1000111
DescriptionTwisted before 16.3.1 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect CGI applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect a CGI application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, aka an "httpoxy" issue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
twisted (PTS)jessie14.0.2-3vulnerable
jessie (security)14.0.2-3+deb8u2vulnerable
stretch16.6.0-2fixed
buster18.9.0-3fixed
bullseye18.9.0-8fixed
sid18.9.0-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
twistedsource(unstable)16.4.0-1unimportant
twistedsourcewheezy(not affected)
twisted-websource(unstable)(unfixed)

Notes

[wheezy] - twisted <not-affected> (For wheezy affected file twcgi.py is in src:twisted-web)
[wheezy] - twisted-web <no-dsa> (Minor issue)
https://twistedmatrix.com/trac/ticket/8623
https://github.com/twisted/twisted/commit/bcac75e6180c9eee4337322c109eb5d1cac51165
No part of Twisted does set HTTP_PROXY based on a Proxy: header, upstream plans
to drop related CGI code in future release

Search for package or bug name: Reporting problems