CVE-2016-10003

NameCVE-2016-10003
DescriptionIncorrect HTTP Request header comparison in Squid HTTP Proxy 3.5.0.1 through 3.5.22, and 4.0.1 through 4.0.16 results in Collapsed Forwarding feature mistakenly identifying some private responses as being suitable for delivery to multiple clients.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs848491

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid3 (PTS)jessie (security), jessie3.4.8-6+deb8u5fixed
stretch (security), stretch3.5.23-5+deb9u1fixed
sid3.5.27-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squid3source(unstable)3.5.23-1medium848491
squid3sourcejessie(not affected)
squid3sourcewheezy(not affected)

Notes

[jessie] - squid3 <not-affected> (Does not affect Squid versions before 3.5.0.1)
[wheezy] - squid3 <not-affected> (Does not affect Squid versions before 3.5.0.1)
Marked as not-affected, vulnerable vulnerability not present due to
the collapsed_forwarding directive beeing added in 3.5.0.1 only
http://www.squid-cache.org/Advisories/SQUID-2016_10.txt
http://www.squid-cache.org/Versions/v4/changesets/squid-4-14956.patch
http://www.squid-cache.org/Versions/v3/3.5/changesets/SQUID-2016_10_a.patch (for squid-3.5 excluding 3.5.22)
http://www.squid-cache.org/Versions/v3/3.5/changesets/squid-3.5-14127.patch (for squid 3.5.22 only)
Vulnerable Squid Versions:
3.5.0.1 up to and including 3.5.22
4.0.1 up to and including 4.0.16
http://www.openwall.com/lists/oss-security/2016/12/17/1

Search for package or bug name: Reporting problems