CVE-2016-1000344

NameCVE-2016-1000344
DescriptionIn the Bouncy Castle JCE Provider version 1.55 and earlier the DHIES implementation allowed the use of ECB mode. This mode is regarded as unsafe and support for it has been removed from the provider.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bouncycastle (PTS)jessie1.49+dfsg-3+deb8u2vulnerable
jessie (security)1.49+dfsg-3+deb8u3vulnerable
stretch (security), stretch1.56-1+deb9u2fixed
buster, sid1.60-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bouncycastlesource(unstable)1.56-1medium

Notes

[jessie] - bouncycastle <ignored> (Intrusive changes, can be mitigated by using a different mode than ECB)
https://github.com/bcgit/bc-java/commit/9385b0ebd277724b167fe1d1456e3c112112be1f

Search for package or bug name: Reporting problems