CVE-2016-10040

NameCVE-2016-10040
DescriptionStack-based buffer overflow in QXmlSimpleReader in Qt 4.8.5 allows remote attackers to cause a denial of service (application crash) via a xml file with multiple nested open tags.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs851058

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1vulnerable
jessie (security)4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u2vulnerable
stretch4:4.8.7+dfsg-11fixed
buster, sid4:4.8.7+dfsg-18fixed
qtbase-opensource-src (PTS)jessie5.3.2+dfsg-4+deb8u2fixed
jessie (security)5.3.2+dfsg-4+deb8u3fixed
stretch (security), stretch5.7.1+dfsg-3+deb9u1fixed
buster, sid5.11.3+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt4-x11source(unstable)4:4.8.7+dfsg-1low851058
qtbase-opensource-srcsource(unstable)5.2.0+dfsg-7medium

Notes

[jessie] - qt4-x11 <ignored> (Minor issue)
[wheezy] - qt4-x11 <ignored> (Minor issue)
CVE assignment specific to http://www.openwall.com/lists/oss-security/2016/12/24/2
http://www.openwall.com/lists/oss-security/2016/12/24/1
https://github.com/qt/qtbase/commit/f1053d94f59f053ce4acad9320df14f1fbe4faac

Search for package or bug name: Reporting problems