CVE-2016-10046

NameCVE-2016-10046
DescriptionHeap-based buffer overflow in the DrawImage function in magick/draw.c in ImageMagick before 6.9.5-5 allows remote attackers to cause a denial of service (application crash) via a crafted image file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-731-1, DSA-3652-1
NVD severitymedium (attack range: remote)
Debian Bugs833730

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)jessie8:6.8.9.9-5+deb8u12fixed
jessie (security)8:6.8.9.9-5+deb8u13fixed
stretch8:6.9.7.4+dfsg-11+deb9u3fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u5fixed
buster, sid8:6.9.10.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.6.2+dfsg-2medium833730
imagemagicksourcejessie8:6.8.9.9-5+deb8u4mediumDSA-3652-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u8mediumDLA-731-1

Notes

https://github.com/ImageMagick/ImageMagick/commit/989f9f88ea6db09b99d25586e912c921c0da8d3f
http://www.openwall.com/lists/oss-security/2016/12/20/3

Search for package or bug name: Reporting problems