CVE-2016-10049

NameCVE-2016-10049
DescriptionBuffer overflow in the ReadRLEImage function in coders/rle.c in ImageMagick before 6.9.4-4 allows remote attackers to cause a denial of service (application crash) or have other unspecified impact via a crafted RLE file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3652-1
NVD severitymedium
Debian Bugs833743

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)stretch8:6.9.7.4+dfsg-11+deb9u8fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u10fixed
buster, buster (security)8:6.9.10.23+dfsg-2.1+deb10u1fixed
bullseye, sid8:6.9.11.24+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksourcewheezy(not affected)
imagemagicksourcejessie8:6.8.9.9-5+deb8u4DSA-3652-1
imagemagicksource(unstable)8:6.9.6.2+dfsg-2833743

Notes

[wheezy] - imagemagick <not-affected> (Vulnerability likely introduced in a version after 6.7.7.10)
https://github.com/ImageMagick/ImageMagick/commit/3e9165285eda6e1bb71172031d3048b51bb443a4
https://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=29710
https://www.openwall.com/lists/oss-security/2016/12/20/3

Search for package or bug name: Reporting problems