CVE-2016-10063

NameCVE-2016-10063
DescriptionBuffer overflow in coders/tiff.c in ImageMagick before 6.9.5-1 allows remote attackers to cause a denial of service (application crash) or have other unspecified impact via a crafted file, related to extend validity.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-756-1, DSA-3726-1
NVD severitymedium (attack range: remote)
Debian Bugs845198

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)jessie8:6.8.9.9-5+deb8u12fixed
jessie (security)8:6.8.9.9-5+deb8u14fixed
stretch8:6.9.7.4+dfsg-11+deb9u3fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u6fixed
buster, sid8:6.9.10.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.6.2+dfsg-2medium845198
imagemagicksourcejessie8:6.8.9.9-5+deb8u6mediumDSA-3726-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u10mediumDLA-756-1

Notes

https://github.com/ImageMagick/ImageMagick/commit/2bb6941a2d557f26a2f2049ade466e118eeaab91
http://www.openwall.com/lists/oss-security/2016/12/20/3

Search for package or bug name: Reporting problems