CVE-2016-10068

NameCVE-2016-10068
DescriptionThe MSL interpreter in ImageMagick before 6.9.6-4 allows remote attackers to cause a denial of service (segmentation fault and application crash) via a crafted XML file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-756-1, DSA-3726-1
NVD severitymedium (attack range: remote)
Debian Bugs845241

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)jessie8:6.8.9.9-5+deb8u12fixed
jessie (security)8:6.8.9.9-5+deb8u14fixed
stretch8:6.9.7.4+dfsg-11+deb9u3fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u6fixed
buster, sid8:6.9.10.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.6.5+dfsg-1medium845241
imagemagicksourcejessie8:6.8.9.9-5+deb8u6mediumDSA-3726-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u10mediumDLA-756-1

Notes

https://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=30797
https://github.com/ImageMagick/ImageMagick/commit/56d6e20de489113617cbbddaf41e92600a34db22
http://www.openwall.com/lists/oss-security/2016/12/20/3

Search for package or bug name: Reporting problems