CVE-2016-10091

NameCVE-2016-10091
DescriptionMultiple stack-based buffer overflows in unrtf 0.21.9 allow remote attackers to cause a denial-of-service by writing a negative integer to the (1) cmd_expand function, (2) cmd_emboss function, or (3) cmd_engrave function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs849705

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unrtf (PTS)jessie0.21.5-3+deb8u1fixed
stretch0.21.9-clean-3fixed
bullseye, sid, buster0.21.10-clean-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unrtfsource(unstable)0.21.9-clean-3849705
unrtfsourcejessie0.21.5-3+deb8u1

Notes

[wheezy] - unrtf <no-dsa> (Minor issue)
http://hg.savannah.gnu.org/hgweb/unrtf/rev/3b16893a6406

Search for package or bug name: Reporting problems