CVE-2016-10127

NameCVE-2016-10127
DescriptionPySAML2 allows remote attackers to conduct XML external entity (XXE) attacks via a crafted SAML XML request or response.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs859135

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-pysaml2 (PTS)stretch3.0.0-5+deb9u1vulnerable
stretch (security)3.0.0-5+deb9u2vulnerable
buster, buster (security)4.5.0-4+deb10u1vulnerable
bookworm, bullseye, sid6.5.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-pysaml2source(unstable)(unfixed)low859135

Notes

[bullseye] - python-pysaml2 <no-dsa> (Minor issue)
[buster] - python-pysaml2 <no-dsa> (Minor issue)
[stretch] - python-pysaml2 <no-dsa> (Minor issue)
[jessie] - python-pysaml2 <no-dsa> (Minor issue)
https://github.com/rohe/pysaml2/issues/366
A proper fix for this issue would be to fix the underlying issue in src:libxml2
https://bugzilla.redhat.com/show_bug.cgi?id=1411794#c12
https://www.openwall.com/lists/oss-security/2017/01/19/5 (for the scope of the CVE)

Search for package or bug name: Reporting problems