CVE-2016-10128

NameCVE-2016-10128
DescriptionBuffer overflow in the git_pkt_parse_line function in transports/smart_pkt.c in the Git Smart Protocol support in libgit2 before 0.24.6 and 0.25.x before 0.25.1 allows remote attackers to have unspecified impact via a crafted non-flush packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs851406, 860990

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cargo (PTS)jessie (security)0.25.0-2~deb8u1fixed
stretch0.25.0-3~deb9u1fixed
buster0.29.0-1fixed
sid0.31.0-3fixed
libgit2 (PTS)jessie0.21.1-3vulnerable
jessie (security)0.21.1-3+deb8u1vulnerable
stretch0.25.1+really0.24.6-1fixed
buster, sid0.27.4+dfsg.1-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cargosource(unstable)0.17.0-1high860990
cargosourceexperimental0.17.0-1~exp1high
libgit2source(unstable)0.25.1+really0.24.6-1high851406

Notes

[jessie] - libgit2 <no-dsa> (Minor issue)
https://github.com/libgit2/libgit2/commit/66e3774d279672ee51c3b54545a79d20d1ada834 (v0.25.1)
https://github.com/libgit2/libgit2/commit/4ac39c76c0153d1ee6889a0984c39e97731684b2 (v0.24.6)

Search for package or bug name: Reporting problems