CVE-2016-10144

NameCVE-2016-10144
Descriptioncoders/ipl.c in ImageMagick allows remote attackers to have unspecific impact by leveraging a missing malloc check.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-807-1, DSA-3799-1
NVD severityhigh
Debian Bugs851485

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)stretch8:6.9.7.4+dfsg-11+deb9u8fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u10fixed
buster, buster (security)8:6.9.10.23+dfsg-2.1+deb10u1fixed
bullseye, sid8:6.9.11.24+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksourcewheezy8:6.7.7.10-5+deb7u11DLA-807-1
imagemagicksourcejessie8:6.8.9.9-5+deb8u7DSA-3799-1
imagemagicksource(unstable)8:6.9.7.4+dfsg-1851485

Notes

Fixed by: https://github.com/ImageMagick/ImageMagick/commit/97566cf2806c0a5a86e884c96831a0c3b1ec6c20
https://www.openwall.com/lists/oss-security/2017/01/16/6

Search for package or bug name: Reporting problems