CVE-2016-10149

NameCVE-2016-10149
DescriptionXML External Entity (XXE) vulnerability in PySAML2 4.4.0 and earlier allows remote attackers to read arbitrary files via a crafted SAML XML request or response.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3759-1
NVD severitymedium
Debian Bugs850716

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-pysaml2 (PTS)stretch3.0.0-5+deb9u1fixed
stretch (security)3.0.0-5+deb9u2fixed
buster, buster (security)4.5.0-4+deb10u1fixed
bullseye, sid6.5.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-pysaml2sourcejessie2.0.0-1+deb8u1DSA-3759-1
python-pysaml2source(unstable)3.0.0-5850716

Notes

https://github.com/rohe/pysaml2/pull/379
https://github.com/rohe/pysaml2/commit/6e09a25d9b4b7aa7a506853210a9a14100b8bc9b

Search for package or bug name: Reporting problems