CVE-2016-10169

NameCVE-2016-10169
DescriptionThe read_code function in read_words.c in Wavpack before 5.1.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted WV file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs853076

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wavpack (PTS)wheezy4.60.1-3vulnerable
jessie4.70.0-1vulnerable
stretch5.0.0-2fixed
buster, sid5.1.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wavpacksource(unstable)5.0.0-2medium853076

Notes

[jessie] - wavpack <no-dsa> (Minor issue)
[wheezy] - wavpack <no-dsa> (Minor issue)
https://sourceforge.net/p/wavpack/mailman/message/35557889/
Fixed by: https://github.com/dbry/WavPack/commit/4bc05fc490b66ef2d45b1de26abf1455b486b0dc (5.1.0)

Search for package or bug name: Reporting problems