CVE-2016-10173

NameCVE-2016-10173
DescriptionDirectory traversal vulnerability in the minitar before 0.6 and archive-tar-minitar 0.5.2 gems for Ruby allows remote attackers to write to arbitrary files via a .. (dot dot) in a TAR archive entry.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-808-1, DSA-3778-1
NVD severitymedium (attack range: remote)
Debian Bugs853075, 853249

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-archive-tar-minitar (PTS)wheezy0.5.2-2vulnerable
wheezy (security)0.5.2-2+deb7u1fixed
jessie (security), jessie0.5.2-2+deb8u1fixed
ruby-minitar (PTS)stretch0.5.4-3.1fixed
buster, sid0.6.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-archive-tar-minitarsource(unstable)(unfixed)medium853249
ruby-archive-tar-minitarsourcejessie0.5.2-2+deb8u1mediumDSA-3778-1
ruby-archive-tar-minitarsourcewheezy0.5.2-2+deb7u1mediumDLA-808-1
ruby-minitarsource(unstable)0.5.4-3.1medium853075

Notes

https://github.com/halostatue/minitar/issues/16
https://github.com/halostatue/minitar/commit/e25205ecbb6277ae8a3df1e6a306d7ed4458b6e4
https://bugzilla.opensuse.org/show_bug.cgi?id=1021740

Search for package or bug name: Reporting problems