CVE-2016-10187

NameCVE-2016-10187
DescriptionThe E-book viewer in calibre before 2.75 allows remote attackers to read arbitrary files via a crafted epub file with JavaScript.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-859-1
NVD severitymedium (attack range: remote)
Debian Bugs853004

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
calibre (PTS)wheezy0.8.51+dfsg1-0.1vulnerable
wheezy (security)0.8.51+dfsg1-0.1+deb7u1fixed
jessie2.5.0+dfsg-1vulnerable
stretch2.75.1+dfsg-1fixed
buster, sid3.4.0+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
calibresource(unstable)2.75.1+dfsg-1low853004
calibresourcewheezy0.8.51+dfsg1-0.1+deb7u1mediumDLA-859-1

Notes

[jessie] - calibre <no-dsa> (Minor issue)
Upstream report: https://launchpad.net/bugs/1651728
Upstream fix: https://github.com/kovidgoyal/calibre/commit/3a89718664cb8cce0449d1758eee585ed0d0433c
http://www.openwall.com/lists/oss-security/2017/01/29/8

Search for package or bug name: Reporting problems