CVE-2016-10188

NameCVE-2016-10188
DescriptionUse-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-832-1, DSA-3853-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bitlbee (PTS)wheezy3.0.5-1.2vulnerable
wheezy (security)3.0.5-1.2+deb7u1fixed
jessie (security), jessie3.2.2-2+deb8u1fixed
buster, sid, stretch3.5.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bitlbeesource(unstable)3.5-1high
bitlbeesourcejessie3.2.2-2+deb8u1highDSA-3853-1
bitlbeesourcewheezy3.0.5-1.2+deb7u1highDLA-832-1

Notes

https://bugs.bitlbee.org/ticket/1281
Fixed by: https://github.com/bitlbee/bitlbee/commit/ea902752503fc5b356d6513911081ec932d804f2 (3.5)
http://www.openwall.com/lists/oss-security/2017/01/30/4

Search for package or bug name: Reporting problems