DescriptionBitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-832-1, DSA-3853-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bitlbee (PTS)wheezy3.0.5-1.2vulnerable
wheezy (security)3.0.5-1.2+deb7u1fixed
jessie (security), jessie3.2.2-2+deb8u1fixed
buster, sid, stretch3.5.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs

Fixed by: (3.5)
When fixing this CVE make sure to apply as well
to not open CVE-2017-5668

Search for package or bug name: Reporting problems