CVE-2016-10196

NameCVE-2016-10196
DescriptionStack-based buffer overflow in the evutil_parse_sockaddr_port function in evutil.c in libevent before 2.1.6-beta allows attackers to cause a denial of service (segmentation fault) via vectors involving a long string in brackets in the ip_as_string argument.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-824-1, DSA-3789-1
NVD severitymedium (attack range: remote)
Debian Bugs854092

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libevent (PTS)wheezy2.0.19-stable-3+deb7u1vulnerable
wheezy (security)2.0.19-stable-3+deb7u2fixed
jessie (security), jessie2.0.21-stable-2+deb8u1fixed
stretch2.0.21-stable-3fixed
buster, sid2.1.8-stable-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libeventsource(unstable)2.0.21-stable-3medium854092
libeventsourcejessie2.0.21-stable-2+deb8u1mediumDSA-3789-1
libeventsourcewheezy2.0.19-stable-3+deb7u2mediumDLA-824-1

Notes

https://github.com/libevent/libevent/issues/318
http://www.openwall.com/lists/oss-security/2017/01/31/17

Search for package or bug name: Reporting problems