CVE-2016-10217

NameCVE-2016-10217
DescriptionThe pdf14_open function in base/gdevp14.c in Artifex Software, Inc. Ghostscript 9.20 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted file that is mishandled in the color management module.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs859662

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)stretch9.26a~dfsg-0+deb9u6fixed
stretch (security)9.26a~dfsg-0+deb9u7fixed
buster9.27~dfsg-2+deb10u3fixed
buster (security)9.27~dfsg-2+deb10u4fixed
bullseye9.52.1~dfsg-1fixed
sid9.53.1~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsourcewheezy(not affected)
ghostscriptsourcejessie(not affected)
ghostscriptsource(unstable)9.20~dfsg-3.1859662

Notes

[jessie] - ghostscript <not-affected> (pdf14_cleanup_parent_color_profiles not yet present)
[wheezy] - ghostscript <not-affected> (pdf14_cleanup_parent_color_profiles not yet present)
https://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=90fd0c7ca3efc1ddff64a86f4104b13b3ac969eb
https://bugs.ghostscript.com/show_bug.cgi?id=697456

Search for package or bug name: Reporting problems