CVE-2016-10507

NameCVE-2016-10507
DescriptionInteger overflow vulnerability in the bmp24toimage function in convertbmp.c in OpenJPEG before 2.2.0 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted bmp file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjpeg2 (PTS)jessie2.1.0-2+deb8u3fixed
jessie (security)2.1.0-2+deb8u8fixed
stretch (security), stretch2.1.2-1.1+deb9u3fixed
buster2.3.0-2fixed
bullseye, sid2.3.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjpeg2source(unstable)2.1.2-1
openjpeg2sourcejessie(not affected)

Notes

[jessie] - openjpeg2 <not-affected> (Vulnerable code introduced later)
Introduced by: https://github.com/uclouvain/openjpeg/commit/33a0e66eb129c4e91b555a6b8dd9eab512fbfeb8 (v2.1.1)
Fixed by: https://github.com/uclouvain/openjpeg/commit/da940424816e11d624362ce080bc026adffa26e8 (v2.1.2)
https://github.com/uclouvain/openjpeg/issues/833

Search for package or bug name: Reporting problems