CVE-2016-10523

NameCVE-2016-10523
DescriptionMQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible with very little bandwidth.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-mqtt-packet (PTS)buster6.0.0-2fixed
bullseye6.9.0-1fixed
bookworm, sid8.1.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-mqtt-packetsource(unstable)(not affected)

Notes

- node-mqtt-packet <not-affected> (Fixed before initial upload to the archive)
https://nodesecurity.io/advisories/75

Search for package or bug name: Reporting problems