CVE-2016-10538

NameCVE-2016-10538
DescriptionThe package `node-cli` before 1.0.0 insecurely uses the lock_file and log_file. Both of these are temporary, but it allows the starting user to overwrite any file they have access to.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs809252

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-cli (PTS)jessie, sid0.4.4~20120516-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-clisource(unstable)(unfixed)unimportant809252

Notes

https://github.com/node-js-libs/cli/issues/81
https://nodesecurity.io/advisories/95

Search for package or bug name: Reporting problems