CVE-2016-10714

NameCVE-2016-10714
DescriptionIn zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to support PATH_MAX characters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1304-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zsh (PTS)jessie5.0.7-5vulnerable
jessie (security)5.0.7-5+deb8u1vulnerable
stretch5.3.1-4fixed
buster5.7.1-1fixed
bullseye, sid5.8-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zshsource(unstable)5.3-1
zshsourcewheezy4.3.17-1+deb7u1DLA-1304-1

Notes

[jessie] - zsh <no-dsa> (Minor issue)
https://sourceforge.net/p/zsh/code/ci/a62e1640bcafbb82d86ea8d8ce057a83c4683d60

Search for package or bug name: Reporting problems